IRONFRONT FANS FORUM
Register Latest Topics
 
 
 


Reply
  Author   Comment  
PissedOffWhiteGuy

Private
Registered:
Posts: 1
Reply with quote  #1 
Okay, I've been trying to install this mod for the last 24 hours.
I've got the base game, I've got the DLC. I've patched the game accordingly before and after installing the DLC. I have converted the files to A3 and I have all the mod folders.

But for some reason, I can't patch the mod content because apparently every single DLC .pbo has an error. "Error found in file @LIB_DLC_1\ADDONS\xxxxxx.PBO". Clicking ignore for all of these will eventually say the mod has been successfully patched or something.

What am I doing wrong here?


On top of this, I'm still getting the following error message when launching ArmA 3.
"Addon 'AiA_Infantry_IF' requires addon 'LIB_sov_characters'. There is no fatal error and the game starts up. The Omaha Beach map appears in the map list, but no other IF content appears in the editor. Attempting to play on any map will result in the game crashing.
0
Barto

Avatar / Picture

IFR Team
Registered:
Posts: 218
Reply with quote  #2 
I have the same problem and I have seen others struggling with the same,but no clear fix.

It would be great if someone could provide a step by step solution to this problem, as it seems to be common. I am afraid it might turn people off the mod even before the IFA3 mod is even complete.

However, what I did is the I ran both the DLC steam and disk patch. At least my US units updated properly. But I am not sure to which extent I will be able to apply future patches..

Again, someone needs to come up with a proper fix or solution!
0
Gunter Severloh

Avatar / Picture

Admin
Registered:
Posts: 2,733
Reply with quote  #3 
Hey fellas,
let me see if i can help, as I been helping on the IFA3 releast thread on BIS forums.

Can you guys post your command line that you are using to start the game up wit the mod?
It should look something like this:
-mod=@CBA_A3;@LIB_DLC_1;@IF_Other_Addons;@IF;@IFA3SA;@IFA3M;@IFA3

I believe your issues stem from not having the IFA3SA unless you do have that, but that error

Addon 'AiA_Infantry_IF' requires addon 'LIB_sov_characters

If im not mistake is because of that, idk i forget, i have seen the error before but its been a while
since I had seen it popup for someone.
This is the wiki for the manual installation for IFA3 https://dev.withsix.com/projects/lib-issue-tracker/wiki/IFA3_manual_install

Did you guys follow this?
I have a tutorial i put together for a guy on the IFA3 thread who was having problems with installation, maybe this can help:
http://forums.bistudio.com/showthread.php?170687-Iron-Front-as-mod-in-Arma-3&p=2835565&viewfull=1#post2835565

Welcome to IF Fan forums Pissedoffwhiteguy!

__________________
0
Barto

Avatar / Picture

IFR Team
Registered:
Posts: 218
Reply with quote  #4 
Hi Gunther,

Thank you for your response.

My command line reads as follows:
"C:XXXX" -mod=@CBA_A3;@LIB_DLC_1;@IF_Other_Addons­;@IF;@IFA3SA;@IFA3M;@IFA3
Which should be OK, I also have IFA3SA in my ARMA 3 folder.

It seems like the DLC isn't converted correctly... However, I was able to get the new IFA3 DLC content as described above (applying both steam and disk patch).
This sort of makes sence as my original version of Iron Front standalone is the disk version and  naturally my ARMA3 is from Steam. It is difficult to verify, but I wouldn't be surprised if those experiencing these issues have the same type of setup.
I am also not sure how successful I will be implementing future patches.

@Pissedoffwhiteguy (haha),
What's your status, did applying both steam and disk patch for the DLC work for you?
*Also, make sure you follow the other steps to detail (run all games once as admin etc) and perhaps do a clean install of ARMA3 with no other addons etc.
*Both ARMA2 and ARMA2CO locations in the conversion tool needs to be the ARMA3 directory.


 
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.