Welcome to the Iron Front Fan Forums!
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
KJSS

Private
Registered:
Posts: 16
Reply with quote  #1 
Tayuk.
         Thanks a lot for your prompt advice. Now sorted. I now have another query after which I`ll try to leave you all in peace for a while.  I`m not exactly senile yet but I am rather ancient and nowhere near being PC proficient, so please bear with me one more time.

My DVD version of `Iron Front` says it is version 1.60.0000. I want to download the `D Day`patch and I find online 4 or 5 different downloads ranging only up to v1.4.  This confuses me, and I really would welcome your further advice on what exactly to download.

Whilst I am at it I say "Thanks again" to the other guys who were so willing to offer their help.  This really does seem to be a great forum with members being so obliging.

KJSS.
0
Tayuk

Avatar / Picture

Retired Admin/IFR
Registered:
Posts: 456
Reply with quote  #2 
Yes it is confusing, but I am assuming you have the original game unpatched at all. As the current game is now at 1.65.

Have a look at this thread which hopefuly (not checked recently) has the various links to the patches.

http://ironfront.forumchitchat.com/post/official-patches-6249912

You can't download and install D-Day until your game is patched up to the current version.

0
KJSS

Private
Registered:
Posts: 16
Reply with quote  #3 
Tayuk. .....Sorry to be a `pain in the neck` here but I`ve tried the link to download 1.05 patch, and it wont download.  Just keeps telling me that "Game v 1.64 is required. Current version is 1.60". I cannot proceed from there.  Just to be specific the latest patch in that link is v1.04-1.05, and that is the one I`ve been trying.

KJSS.
0
Tayuk

Avatar / Picture

Retired Admin/IFR
Registered:
Posts: 456
Reply with quote  #4 
The way the versions are numbered is a bit confusing, as one number referes to the game engine and one number refers to the game, the patch numbers refer to the game version, which yours is 1.0 as its a clean install from the DVD.

But for the purposes of this exercise Ignore the 1.60 number,  These are the patches in the order they were released, it looks like you can start your patches from 1.03 (the 3rd patch) as this updates from version 1.0 which is at it comes out of the box (DVD). Then 1.04 and finally 1.05. Then your game will be upto date. and in game the version number you see on your start screen should be 1.65.

Once thats done then you should be able to install D-Day hopefully without issues.

  • 1.00 - The basic game version after installation.
  • 1.01- First patch
    • 1.01a "hotfix" - Quick hotfix for 1.01, to solve a critical issue. DO NOT USE/INSTALL THIS HOTFIX.
  • 1.02- Second patch
    • 1.00-1.02 - With this installer you can upgrade your game version from 1.00 to 1.02.
    • 1.01-1.02 - With this installer you can upgrade your game version from 1.01 to 1.02.
  • 1.03- Thirt patch
    • 1.00-1.03 - With this installer you can upgrade your game version from 1.00 to 1.03.
    • 1.02-1.03 - With this installer you can upgrade your game version from 1.02 to 1.03.
  • 1.04- Fourth patch
    • 1.03-1.04 - With this installer you can upgrade your game version from 1.03 to 1.04.
  • 1.05- Fifth patch
    • 1.04-1.05 - With this installer you can upgrade your game version from 1.04 to 1.05. (Latest!)

You will need to make sure the patches are the ones for the DVD and not the downloaded version.

I hope that helps.

0
KJSS

Private
Registered:
Posts: 16
Reply with quote  #5 
Tayuk.
         Things are much clearer now thanks to you, I really am obliged to you. I`ll give it another go maybe later tonight or tomorrow.  I`ll let you know out of courtesy how I make out.  Thanks again.


0
Poor Old Spike

Avatar / Picture

IFR Team
Registered:
Posts: 415
Reply with quote  #6 
Hey KJSS for good measure you might also like to have a look at this thread about patching-
http://ironfront.forumchitchat.com/post/updating-basic-iron-front-lib44-6501150
0
Poor Old Spike

Avatar / Picture

IFR Team
Registered:
Posts: 415
Reply with quote  #7 
Hey and thanks for giving me the idea for doing a tutorial about the editor, I just posted one in the Help thread-
http://ironfront.forumchitchat.com/post/iron-front-editor-tutorial-6564610?pid=1279850674#post1279850674
0
Poor Old Spike

Avatar / Picture

IFR Team
Registered:
Posts: 415
Reply with quote  #8 
I posted this in the Mission Editing thread but on second thoughts I should have posted it here for a wider audience, so here goes-

KJSS can't install the second IFL44 patch, I sent him a spare brandnew game disk but he's still having exactly the same problem when he tries to patch it, namely the first patch installs fine (1.00-1.03), but the second patch (1.03-1.04) refuses to install!
Below is what he's just told me, one of the error messages mentions the lib_61k ifa for some unknown reason, has anybody got any ideas to help him?

"Completely uninstalled the old, then installed from your new game disk. Then tried installing patches. Got same old results I`m afraid with patch 1.03-1.04.  Then tried downloading fresh patches from different source. Got same results. Did the same yet again from another different source, still got same results. So......I guess there`s nothing wrong with my game disk and the issue lies between patch 1.03-1.04 and my PC, though I can`t imagine what that issue is.
 
Every time I try installing that particular patch I get the following message:-  "Update 1.62-1.64\DLL\TBB3MALLOC_BI.DLL.UPD cannot be applied.error xdelta3 returned  error code 1. Patch file probably damaged. you may need to download it again. Error in file DLL\tbb4malloc_bi dll. phase 1"
 
If I then try to play the game I get a small window saying "Warning. Signature of C\Program FilesAWAR\Iron Front Liberation 1944\IF\addons\lib_61k.ifa is wrong".
[ This is because the first patch actually worked and changed game to version 1.62.  The same thing was happening with my own disk but the game still plays okay with no bother ]"
0
TurkishSoap

Avatar / Picture

IFR Team
Registered:
Posts: 98
Reply with quote  #9 
He should download the patches from the official website found here http://ironfront.deepsilver.com/en/patch-2 as I found that on other websites the patches are corrupted !
0
Poor Old Spike

Avatar / Picture

IFR Team
Registered:
Posts: 415
Reply with quote  #10 
Thanks TurkishSoap he just tried it but it didn't work, he tells me this-

"I tried downloading DeepSilver patches once again, but when installing them to game I got same old results. There is obviously an issue between my PC and that 2nd [ 1.03-1.04 ] patch"
0
Poor Old Spike

Avatar / Picture

IFR Team
Registered:
Posts: 415
Reply with quote  #11 
If he can't fix the problem the IF community will lose a player.
I see there's a reference to the Russian 61k gun in one of his error messages (below) does that give a clue to anybody?

If I then try to play the game I get a small window saying "Warning. Signature of C\Program FilesAWAR\Iron Front Liberation 1944\IF\addons\lib_61k.ifa is wrong".
0
kju

RM Team
Registered:
Posts: 388
Reply with quote  #12 
re-install
scan hdd for issues
check ram for issues
0
Poor Old Spike

Avatar / Picture

IFR Team
Registered:
Posts: 415
Reply with quote  #13 
okay i'll tell him..[smile]
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.